eclipse and gdb

I’m using Eclipse with gdb to develop and debug llvm.

You need to use the “Eclipse IDE for C/C++ Developers” version for that (also sometimes called “Eclipse CDT” – CDT is the C++ component), though you can also download any other Eclipse version and just install CDT on top of it. As for versions, it’s best to use the most recent version you can find. Should work fine on all Linux distros, though some advanced features require a minimum gdb version.

As for creating the Eclipse project, think the simplest approach is to configure as usual, then create a “makefile project” in Eclipse and tell it to use the existing makefiles created under OBJ_ROOT – don’t let Eclipse manage your makefiles.

  • Alon