ENABLE_TIMESTAMPS and update to CMake v3.5.2

I am in the middle of the fun and games of updating my out-of-tree sources to the LLVM head revisions, and after updating to CMake v3.5.2 I am now getting a warning that ‘ENABLE_TIMESTAMPS’ is being ignored.

Has support for embedding the timestamp in the build been removed or is there a new way of configuring it? I generally build internal transitional builds with this enabled so that I can tell one build from another reasonably easily, especially when the corresponding sources are not committed and I can’t use an SVN revision number to track it.

Thanks,

MartinO

Hi,

Okay thanks - I seem to have missed reading that discussion.

  MartinO

Hmm, but reading it now it seems that the issue is really whether it is on by default, and not when explicitly selected (as I am doing).

It's not a big deal, just curious.

  MartinO