f95 problem with SPEC2K

Anyone know what to do about this:

make[4]: Leaving directory `/proj/llvm/llvm-test-1/External/SPEC/CFP2000/173.applu'
make[4]: Entering directory `/proj/llvm/llvm-test-1/External/SPEC/CFP2000/178.galgel'
/usr/bin/f95 -w -S -O2 /opt/spec/CPU2000v1.3.1/benchspec//CFP2000/178.galgel/src/modules.f90 -o modules.c -fixed -kind=byte -dcfuns -dusty
f95: unrecognized option '-kind=byte'
f951: warning: unrecognized gcc debugging option: u
f951: warning: unrecognized gcc debugging option: u
f951: error: unrecognized command line option "-fixed"
make[4]: *** [modules.c] Error 1

?

This man page:

says there's no such option as -kind

Do I need some special version of f95 to run the SPEC2K tests?

Reid.

If I'm correct, f95 has nothing to do with GCC.
GCC has the gfortran compiler, but this is a Fortran-to-binary compiler.
You want the NAG f95 compiler, which allows Fortran-to-C translation, what you appear to be doing.
NAG Fortran Compiler | nag (it's commercial, but I think at least Chris has a license for this).

greetings,

Kenneth

Hi Kenneth,

>
> ?
>
> This man page:
> gfortran(1): GNU Fortran compiler - Linux man page
>
> says there's no such option as -kind
>
> Do I need some special version of f95 to run the SPEC2K tests?

If I'm correct, f95 has nothing to do with GCC.

As I just discovered, gfortran creates an f95 symbolic link to gfortran
when it is installed.

GCC has the gfortran compiler, but this is a Fortran-to-binary compiler.
You want the NAG f95 compiler, which allows Fortran-to-C translation,
what you appear to be doing.

Yes, I believe I do.

NAG Fortran Compiler | nag (it's commercial, but I think at
least Chris has a license for this).

It seems our "sanity check" in configure for f95 isn't correct. Its
checking for NAG f95, not gfortran. However, the sanity check "passed"
on the gfortran link for f95. I'll fix that and see if SPEC will
complete.

Thanks for pointing it out !

Reid.

When you get a chance, please tweak the configure script to reject gfortran's 'f95'. This would be a nasty suprise for people with gfortran installed.

Thanks!

-Chris