I'm trying to compile some C++ code on Windows that contains blocks. The compiler gives me the error that the blocks language feature is not enabled and that I should enable it with "-fblocks". When I add that compiler flag, the compile fails immediately saying "unknown argument: '-fblocks'"

Is this perhaps an incomplete feature?

Eric Mader

It sounds like you are using the clang-cl driver, perhaps “-Xclang -fblocks” might work.

That seems to have done the trick!