ffmpeg on fedora core 8

hello mailinglist,

i currently try to compile ffmpeg on a 64bit fedora-core 8 machine using llvm2.3.
the “good” things first:

everything works fine on a 32bit ubuntu-machine using llvm-2.3 (actually i do not know if that is grace to ubuntu or grace to 32bit)
when using the normal gcc on the 64bit fc8 machine, everything works too.

now the “bad” thing: it does not work on fc8 with llvm-2.3
the error looks as follows:

./ffmpeg_g -i 1minute.mov -an -y /tmp/1minute.avi
FFmpeg version SVN-r14075, Copyright (c) 2000-2008 Fabrice Bellard, et al.
configuration: --disable-ffserver --disable-ffplay --disable-mmx --disable-mmx2 --disable-ssse3 --disable-armv5te --disable-armv6 --disable-iwmmxt --disable-altivec --disable-network --disable-ipv6 --disable-zlib --disable-vhook --disable-stripping --extra-cflags=-emit-llvm -c --extra-ldflags=-emit-llvm -c --enable-cross-compile --cross-prefix=llvm-
libavutil version: 49.7.0
libavcodec version: 51.58.0
libavformat version: 52.16.0
libavdevice version: 52.0.0
built on Jul 5 2008 11:20:26, gcc: 4.2.1 (Based on Apple Inc. build 5555) (LLVM build 2.3)
./ffmpeg_g: unrecognized option ‘-i’

so it seems to forget about its command-line-args. i also tried SVN-r15424 - with no chance.

does anyone have a clue how i could try to resolve this issue?
if you need further information - let me know.

and thank you in advance, of course :slight_smile:

Hi,

does anyone have a clue how i could try to resolve this issue?
if you need further information - let me know.

does it work correctly if you compile at -O0?

Ciao,

Duncan.

Please file a bug. It should not be difficult to extract out the option processing portion and turn it into a smaller test case.

Evan