GCC 4.1.2 + LLVM 3.4

Hi all

Is there anybody tried to build the latest LLVM 3.4 by GCC 4.1.2 ?

Sorry that 4.1.2 is really the ancient version but for my application there is the C++ ABI problem so that for maximal compatibility I have to use GCC 4.1.2 .

And now I tried to build a pure static version but when it built the last libLTO.so it reported the linking issue about fPIC but I have enabled that option everywhere, once switched the compiler to GCC 4.4.6 shipped from CentOS6 everything is fine.

Thanks !

Hi Bo,

Is there anybody tried to build the latest LLVM 3.4 by GCC 4.1.2 ?

Afraid I can't help here (I've no idea if LLVM 3.4 should be
compilable with that GCC), but I should warn you:

Sorry that 4.1.2 is really the ancient version but for my application there
is the C++ ABI problem so that for maximal compatibility I have to use GCC
4.1.2 .

LLVM 3.5 is going to require at least GCC 4.7 since we're using C++11
now. Unless you intend to freeze your LLVM, you may want to rethink
upgrading.

Cheers.

Tim.