Git mirror very slow

14 KB/s now. Yesterday 40 KB/s.

Is that transitory or there is no enough bandwidth on llvm.org?

Hi Oscar,

14 KB/s now. Yesterday 40 KB/s.
Is that transitory or there is no enough bandwidth on llvm.org?

Something is wrong on your side:

$ git clone http://llvm.org/git/llvm.git
Cloning into llvm...
remote: Counting objects: 607409, done.
remote: Compressing objects: 100% (118270/118270), done.
Receiving objects: 2% (13924/607409), 3.87 MiB | 402 KiB/s

Oscar, is it slower always? whatever to fetch each repository.git?

...Takumi

Hello Anton and Takumi.

Anton Korobeynikov <anton@korobeynikov.info> writes:

14 KB/s now. Yesterday 40 KB/s.
Is that transitory or there is no enough bandwidth on llvm.org?

Something is wrong on your side:

$ git clone http://llvm.org/git/llvm.git
Cloning into llvm...
remote: Counting objects: 607409, done.
remote: Compressing objects: 100% (118270/118270), done.
Receiving objects: 2% (13924/607409), 3.87 MiB | 402 KiB/s

Curious. I just cloned LLVM from repo.or.cz and Clang from gitorious.org
at full speed (1 MB/s). Maybe it's something on the path from here to
llvm.org. Thanks for checking.

Takumi:

Tried yesterday and today. Sometimes there were short spikes of 100 KB/s
but the average speed was 40 KB/s (yesterday) and 14 KB/s (today). IIRC
also tried several times months ago and gave up due to the slowness, but
I don't recall the exact figures.

Hello Anton and Takumi.

Anton Korobeynikov <anton@korobeynikov.info> writes:

14 KB/s now. Yesterday 40 KB/s.
Is that transitory or there is no enough bandwidth on llvm.org?
Something is wrong on your side:

$ git clone http://llvm.org/git/llvm.git
Cloning into llvm…
remote: Counting objects: 607409, done.
remote: Compressing objects: 100% (118270/118270), done.
Receiving objects: 2% (13924/607409), 3.87 MiB | 402 KiB/s

Curious. I just cloned LLVM from repo.or.cz and Clang from gitorious.org
at full speed (1 MB/s). Maybe it’s something on the path from here to
llvm.org. Thanks for checking.

Takumi:

Tried yesterday and today. Sometimes there were short spikes of 100 KB/s
but the average speed was 40 KB/s (yesterday) and 14 KB/s (today). IIRC
also tried several times months ago and gave up due to the slowness, but
I don’t recall the exact figures.

Looks like a hiccup in the network between you and llvm.org. I just tried a fresh clone:

remote: Counting objects: 607523, done.
remote: Compressing objects: 100% (118384/118384), done.
Receiving objects: 54% (328063/607523), 61.90 MiB | 3.86 MiB/s

It’s up to speed for me. :slight_smile:

It might tend, "git-clone is not slow although git-fetch is too slow",
sometimes.
FYI, I have not met network bottlenecks.

...Takumi