Help with Shell Script Property List Format on Mac

Hi lldb-dev,

On my Mac, I’ve tried to get the shell script property list format to work as described in http://lldb.llvm.org/symbols.html. However, I can’t seem to get it to work.

To make sure it would do the right thing, I moved my dSYM and sources around, all on my local drive, with very simple repro code.

I created a shell script, named after the library’s uuid, here are the contents:

#!/bin/sh

plist header

echo “<?xml version=\"1.0\" encoding=\"UTF-8\"?>”
echo “”
echo “<plist version=“1.0”>”

main body

echo “”

echo “150BADFD-271A-3C5C-9710-A6C56EF5A06E”
echo “”
echo “DBGArchitecture”
echo “x86_64”
echo “DBGBuildSourcePath”
echo “/localsb/XTools/TestTool”
echo “DBGSourcePath”
echo “/mathworks/home/sburke/Library/Developer/Xcode/DerivedData/TestTool-dokupfoqmgtapzcyhynqroozmcya/Build/Products/Debug”
echo “DBGDSYMPath”
echo “/localsb/XTools/TestTool/libTestDylib.dylib.dSYM/Contents/Resources/DWARF/libTestDylib.dylib”
echo “DBGError”
echo “Could not remap sources for libTestLib.dylib”
echo “”

echo “”

plist footer

echo “”

exit 0

The DBGBuildSourcePath value I got right from the output of dwarfdump on the dSYM.
Then I set the defaults like so:

defaults write com.apple.DebugSymbols DBGShellCommands -string /localsb/XTools/TestTool/uuids/150BADFD-271A-3C5C-9710-A6C56EF5A06E

I start my target, hit a breakpoint, try to step in, and I don’t get the symbols.
Using ‘target symbols add’ manually with the dSYM does resolve the symbols correctly and I am able to step into the code.
However, the shell script workflow does not seem to be working.

Therefore, I must not be doing this right or there is some restriction I am unaware of. Any suggestions?

Thanks,
Sara