How build the LLVM dragonegg on macos10.14?

I read the book “Getting Started with LLVM Core Libraries”, follow the book, I want to build a dragonegg-3.3 on my mac, so I download the dragonegg-3.3 source code form ‘http://llvm.org/releases/3.3/dragonegg-3.3.src.tar.gz’, and then I build the dragonegg-3.3 use command in the book

GCC=gcc-4.6 LLVM_CONFIG=directory_where_llvm_installed/bin/llvm-config make

but my mac doesn’t have gcc-4.6, and I can’t install gcc-4.6 on now macos10.14! , It seems the gcc-4.6 is an older version of gcc not suitable for now macos10.14.

what should I do for building or installing the dragonegg on macos10.14, thanks a lot!

[

李士林

15267030696@163.com

](https://maas.mail.163.com/dashi-web-extend/html/proSignature.html?&name=李士林&uid=15267030696%40163.com&ftlId=1&iconUrl=https%3A%2F%2Fmail-online.nosdn.127.net%2Fqiyelogo%2FdefaultAvatar.png&items=["15267030696%40163.com"])

签名由 网易邮箱大师 定制