How to enable C as a target

Hi,

How to enable C as a target while configuring LLVM…

Can i do ’ --enable-targets = x86,c ’ to make it work?

´ Sarath!!!
`·.¸.·´

Sarath Chandra wrote:

Hi Nick,

I need the module.ll file. Now how can i configure LLVM to enable
“c” target? Is it that i need to build from the scratch? Is there any
way to enable ‘c’ target also?

Yes. To quote myself:

I think you’re looking for configure --enable-targets=x86,cbe .

:slight_smile:

Nick

Hi Sarah,

     How to enable C as a target while configuring LLVM...

Can i do ' --enable-targets = x86,c ' to make it work?

it should be x86,cbe not x86,c.

Ciao, Duncan.

use --enable-targets=x86,cbe
(C BackEnd if I remember correctly)

Thanks all. It’s working now.