How to run single compiler-rt test in monorepo?

Hello all,

I am having trouble running only a single lit-based test of compiler-rt.
My folder structure is: inside the llvm monorepo checkout, I have a dir “build” with subdir “buildtrunk”. I ran cmake inside “buildtrunk” and also run ninja from there.

For LLVM I can do the following:

cd build/buildtrunk/test
…/bin/llvm-lit --show-tests .

And it shows all tests discovered of the llvm main library, but not tests of for example clang or compiler-rt.
Running a single test works aswell:

…/bin/llvm-lit -v tools/yaml2obj/versym-section.yaml
– Testing: 1 tests, 1 workers –
PASS: LLVM :: tools/yaml2obj/versym-section.yaml (1 of 1)

However whatever I try, I have not succeeded in having Lit discover the compiler-rt tests, and I didn’t manage to run just one compiler-rt test. Information online is sparse, and I didn’t find it there either.

What is are command / How do I run a single lit-based compiler-rt test?

Thanks a lot,
Johan

I usually run single tests (compiler-rt and LLVM) as
LIT_FILTER= ninja check-

It’s also possible to run lit on a test directory that’s constructed within the build dir, e.g.:

~/src/builds/llvm-project-master-RA (0) $ ./bin/llvm-lit projects/compiler-rt/test/profile/Profile-x86_64h/instrprof-basic.c

vedant

Thanks Vitaly and Vedant.
Both methods worked for me.
The trick for running llvm-lit directly is to add the arch in the path (actually part of the directory structure inside the build folder, so I could have known).

cheers,
Johan