InitHeaderSearch.cpp ices gcc <= 4.5

Hi;

I see the following compiler crash with gcc 4.5 while building llvm-3.0 release:

/usr/src/packages/BUILD/llvm-3.0/tools/clang/lib/Frontend/InitHeaderSearch.cpp: In member function ‘void::InitHeaderSearch::AddMinGWCPlusPlusIncludePaths(llvm::StringRef, llvm::StringRef, llvm::StringRef)’:
/usr/src/packages/BUILD/llvm-3.0/tools/clang/lib/Frontend/InitHeaderSearch.cpp:192:1: error: unrecognizable insn:
(insn 192 191 46 2 /usr/src/packages/BUILD/llvm-3.0/include/llvm/ADT/Twine.h:180 (set (reg:DI 23 xmm2)
(plus:DI (reg:DI 23 xmm2)
(mem/u/c/i:DI (symbol_ref/u:DI (".LC14") [flags 0x2]) [0 S8 A64]))) -1 (expr_list:REG_EQUIV (plus:DI (reg/f:DI 7 sp)
(mem/u/c/i:DI (symbol_ref/u:DI ("
.LC14") [flags 0x2]) [0 S8 A64]))
(nil)))
/usr/src/packages/BUILD/llvm-3.0/tools/clang/lib/Frontend/InitHeaderSearch.cpp:192:1: internal compiler error: in extract_insn, at recog.c:2103
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugs.opensuse.org/> for instructions.

Best bet is to file a bug with SuSE here.

-eric

Hi;

I can get this fixed for SUSE but I thought you would like to support gcc
4.5 :wink:

Well, we'd like, but this is gcc bug, not clang/llvm's one.

Hi;

The workaround is to compile first stage compiler with

–with-optimize-option="-O0"

configure option. Hope that helps someone else too :slight_smile:

Regards.