Kaleidescope lesson #3

I tried to compile and run the code from the Kaleidescope tutorial: http://llvm.org/docs/tutorial/LangImpl3.html

While the compilation worked fine, the run did not. I'm using the version of llvm from svn for 12/15/09. In gdb
I get this stack trace, and never see the "ready>" prompt. Apparently it's dying inside constructors in the
headers somewhere.

#0 0x00000036b502e21d in raise () from /lib64/tls/libc.so.6
#1 0x00000036b502fa1e in abort () from /lib64/tls/libc.so.6
#2 0x00000036b5027ae1 in __assert_fail () from /lib64/tls/libc.so.6
#3 0x0000002a95ff9c25 in RegisterPass (this=0x519080, PI=@0x2a964e2ea0) at Pass.cpp:227
#4 0x0000002a95ff9d8f in llvm::PassInfo::registerPass (this=0x2a964e2ea0) at Pass.cpp:313
#5 0x0000002a95ff0745 in llvm::PassInfo::PassInfo$base () at Debug.cpp:64
#6 0x0000002a95ff07a1 in llvm::RegisterPass<llvm::DominatorTree>::RegisterPass () at Debug.cpp:64
#7 0x0000002a95fe6a55 in __static_initialization_and_destruction_0 (__initialize_p=1, __priority=65535) at Dominators.cpp:55
#8 0x0000002a95fe6abf in global constructors keyed to VerifyDomInfo () at Dominators.cpp:345
#9 0x0000002a9604c332 in __do_global_ctors_aux () from /work/sbrandt/clang/lib/libCIndex.so
#10 0x0000002a95b2875b in _init () from /work/sbrandt/clang/lib/libCIndex.so
#11 0x0000002a97e48000 in ?? ()
#12 0x00000036b4e0b04f in _dl_init_internal () from /lib64/ld-linux-x86-64.so.2
#13 0x00000036b4e00abb in _dl_start_user () from /lib64/ld-linux-x86-64.so.2
#14 0x0000000000000001 in ?? ()
#15 0x0000007fbfffe8db in ?? ()
#16 0x0000000000000000 in ?? ()

Any insight as to what I should do would be helpful.

It was compiled with gcc-4.2.1 with 64 bit support unser Red Hat 4.

Cheers,
Steve