liblldCommon is broken at head

ninja all check-xray
[0/981] Building libLLVMTableGen for native TableGen...
ninja: no work to do.
[673/979] Linking CXX shared library lib/liblldCommon.so.6.0.0svn
FAILED: lib/liblldCommon.so.6.0.0svn
: && /usr/bin/clang++-3.9 -fPIC -Wpedantic -fPIC -fvisibility-inlines-hidden -Werror=date-time -std=c++11 -Wall -W -Wno-unused-parameter -Wwrite-strings -Wcast-qual -Wmissing-field-initializers -pedantic -Wno-long-long -Wcovered-switch-default -Wnon-virtual-dtor -Wdelete-non-virtual-dtor -Wstring-conversion -fcolor-diagnostics -ffunction-sections -fdata-sections -O3 -Wl,-z,defs -fuse-ld=gold -Wl,-rpath-link,/usr/local/google/home/dberris/xray/llvm-build/./lib -Wl,-O3 -Wl,--gc-sections -shared -Wl,-soname,liblldCommon.so.6 -o lib/liblldCommon.so.6.0.0svn tools/lld/Common/CMakeFiles/lldCommon.dir/Reproduce.cpp.o tools/lld/Common/CMakeFiles/lldCommon.dir/TargetOptionsCommandFlags.cpp.o tools/lld/Common/CMakeFiles/lldCommon.dir/Threads.cpp.o tools/lld/Common/CMakeFiles/lldCommon.dir/Version.cpp.o -Wl,-rpath,"\$ORIGIN/../lib" lib/libLLVMCodeGen.so.6.0.0svn lib/libLLVMMC.so.6.0.0svn lib/libLLVMOption.so.6.0.0svn lib/libLLVMSupport.so.6.0.0svn lib/libLLVMTarget.so.6.0.0svn && :
/usr/bin/../lib/gcc/x86_64-linux-gnu/6.3.0/../../../../include/c++/6.3.0/thread:137: error: undefined reference to 'pthread_create'
/usr/bin/../lib/gcc/x86_64-linux-gnu/6.3.0/../../../../include/c++/6.3.0/thread:137: error: undefined reference to 'pthread_create'
clang: error: linker command failed with exit code 1 (use -v to see invocation)
[722/979] Building X86GenInstrInfo.inc...

I'm currently at r315954.

Anybody else seeing this?

-- Dean

hi,

found this, too. LLVM_PTHREAD_LIB is not linked to lldCommon, which
fails if you build with shared libs.

Seems introduced in r315725 and fixed in r315988.

Can confirm it’s fixed now, thanks Takumi!

Cheers