Linker errors after installing/compiling LLVM/CLANG

Hi All,

I am looking for the best way to install LLVM+clang, but I do not seem to find a way that works for me.

I followed the steps in this document Getting Started with the LLVM System — LLVM 9 documentation except that I created the following folder structure as I do not want clang and llc to go to /usr/local

LLVM-9
llvm-project (cloned from github)
install

I ran the following command line from the build directory in llvm-project as described in the doc, but added the DLLVM_OPTIMIZED_TABLEGEN=On variable :

cmake -G Xcode -DLLVM_ENABLE_PROJECTS=clang -DCMAKE_INSTALL_PREFIX=/Users/joan/LLVM-9/install -DLLVM_OPTIMIZED_TABLEGEN=On …/llvm

The cmake command above seems to work ok, but after that, when I compile the “install” or “build_all” schemes I get a lot of linker errors. Such as these ones and more:

clang: error: no such file or directory: ‘/Users/joan/LLVM-9/llvm-project/build/Debug/lib/libclangAST.a’
clang: error: no such file or directory: ‘/Users/joan/LLVM-9/llvm-project/build/Debug/lib/libclangLex.a’
clang: error: no such file or directory: ‘/Users/joan/LLVM-9/llvm-project/build/Debug/lib/libclangBasic.a’

Up until recently, I have worked with LLVM 7.0 and all what I did was downloading both llvm and clang from llvm.org, copied clang into llvm/tools, and ran the cmake application (not command line). That kind of worked except for some minor glitches but of course I didn’t get the benefits of git.

So what am I doing wrong now? Why I’m getting such linker errors?

It seems that a few required libraries are not created, but I do not understand why. Any ideas?

Thanks,

John

John, I compiled and installed to /usr/local all the projects under llvm except llgo yesterday. The three files you noted are in

…/llvm-project/build/lib

I do not have a llvm-project/build/Debug directory.

Xubuntu 19.04. llvm downloaded from github on 6/18 using instructions from the page you note.

cmake -G Ninja -DLLVM_ENABLE_PROJECTS=“clang;clang-tools-extra;compiler-rt;debuginfo-tests;libclc;libcxx;libcxxabi;libunwind;lld;lldb;llvm;openmp;parallel-libs;polly;pstl” -DLLVM_USE_LINKER=lld -DCMAKE_BUILD_TYPE=“Release” …/llvm

Installed additional packages as needed.

Neil