lit support for Python3

Hi all,

In the past there was some interest in having lit supporting use with Python3, which had become the default on some Linux distributions.

I’ve been working on this recently and as of r188398, the LLVM/Clang tests all run and pass on my system with Python 3.3. There are still some quality of implementation issues to iron out, and there may be problems with lit-based tests in other repositories.

If anyone is interested in this support, I’d appreciate it if you changed your setup to use Python3 for running the tests and let me know (or file bugs) for any issues you find.

Thanks,

  • Daniel

If anyone is interested in this support, I'd appreciate it if you changed
your setup to use Python3 for running the tests and let me know (or file
bugs) for any issues you find.

Excellent! The only reason I set my interpreter back to 2.7 a while
back was LLVM. Back to 3.2 now.

Tim.

P.S. All passes here too.

Great work, Daniel. All LLVM tests pass for me on trunk when running with
Python 3.4 alpha.

Now get rid of pre-2.6 Python support :wink: Not only it helps clean-up code,
by 2-and-3 coexistence is much easier.

Eli

Awesome! Thanks for all the hard work!

– Sean Silva

It looks like Daniel was able to add py3k support fairly cleanly. I'm not
sure how much of a difference removing pre-2.6 support would make at this
point. (also, let's not start down the road of that discussion, as it has
been quite incendiary in the past)

-- Sean Silva

support is much easier the fewer 2.x releases you must support. We've
required 2.7 for some time now (although we don't yet support running on
3.x, we try to write most new Python to be dual compatible). We're even
planning to bump the minimum to 2.7.3+ due to the number of unicode
strings bugs in <=2.7.2 (these bugs make dual compatibility especially
difficult). The world did not end for us when we dropped 2.6 support. I
encourage other projects to do the same.