LLDB-4.7 always starts server on Linux

Hi,

When I run lldb-4.6 that I apt-get on my Ubuntu 14.04 box, it runs as a single process directly monitoring the target. When I run lldb-4.7 that I built from sources, it starts lldb-server. Is this a legitimate policy change or I miss some configuration option? I mean, is it possible to run lldb-4.7 as a single process - the way 4.6 does?

Thanks,
Eugene

This is the new way forward. Why is it better? Because it will ensure that remote debugging is just as good as local debugging. Otherwise remote debugging is something no one ever plays with and when people use it it doesn't work very well. It also means if something serious goes wrong, it can stop lldb itself from crashing and keeps LLDB out of the signal chain and many other things that can be beneficial when spawning child processes.

Is there a reason you want the old behavior back?

Greg

Thanks for info. Still, is there a way to force the old behavior on Linux? I am creating a C++ program that does not involve starting command interpreter, and apparently I mess up LLDB state somewhere. Now, looking at one state machine in a single process is much easier that looking at two interconnected state machines in two different processes.

I found platform.plugin.linux.use-llgs-for-local setting - does it still work?

Thanks,
Eugene

does it still work?

We just checked and 50% of the tests are failing.

In fact, we’ve just removed this code from the tree. This is exactly the way OSX debugs local processes. Now all OSX/iOS/Android/Linux local/Linux remote all share the most code possible.