LLDB break comm add doesn't use libedit

I wanted to ask whether it is intentional that breakpoint command add does not use libedit, so anytime I press Delete I get ^H instead removing last character like in regular command prompt, no arrows working too.

Also I think it would be maybe more reasonable to launch $EDITOR to edit these commands instead typing them one by one in console.

Regards,

Are you adding a Python or an lldb command breakpoint command?

The interaction between lldb's input and Python is pretty rocky at present, both for adding commands and in the "script" command itself. It will take somebody who's eager to dig into Python's input functionality and figure out how to get it to work correctly using our input streams to make this smooth. We'll get around to it at some point as it is pretty annoying, but it is not on the top of our queue.

If you are adding lldb command breakpoint commands, then I'm not seeing the behavior you describe. We don't hook up the command completer or history to adding breakpoint commands, though that wouldn't be too hard to do. But delete and left and right arrows work for me on Mac OS X.

Not sure about firing up the editor, for lldb command commands it would mean we could not use the command completer or history. Also, I'm not sure I would want to have to pop over to emacs to write a two-line breakpoint command, so I don't think it should be the default mode. But it would be fine to add that as an option. Might also be nice to have an option to take the command text from a file so you could easily reuse it.

Jim