LLDB python API inconsistent with lldb tool on linux

Hi all,

I have kind of a strange problem. First of all, here is the short version.

My crash analysis tool
https://github.com/bnagy/francis/tree/master/exploitaben works fine on
OSX, but on linux it fails to correctly handle some ( but not all )
faulting programs. The lldb tool in the same environment and on the
same inputs works as expected. Ubuntu 15.04, lldb 3.6.

Here’s the longer version.

I am analysing crashes (from afl-fuzz, which may be involved). The
basic harness in exploitaben.py is a light modification of one of the
LLDB API example tools process_events.py. It has worked correctly for
many crashes on OSX, so I feel like the basic approach is sound. Here
are some observations.

I built the basic tests from https://github.com/jfoote/exploitable.
When I run, for example

exploitaben.py – ~/src/exploitable/exploitable/tests/bin/testAbortSignal.test

I get correct output.

When I run a fault, like

exploitaben.py – pdftoppm -r 16
/mnt/nfs/raid/fuzz/poppler/smoke-S1/crashes/id:000000,sig:06,src:000000,op:havoc,rep:4

I get