lldb-server for MIPS

Hi everyone,

I'm looking into lldb-server and trying to use it with MIPS devices (32 and 64 bit) running Android. Could anyone confirm that lldb-server is/isn't working for this configuration? Is anyone currently working on it? Or using it with this set-up at all?

Ideally I would like to be able to built lldb-server for MIPS and investigate its functionality. However, I'm not even able to generate the binaries. I get a lot of linking errors indicating that the `__atomic_fetch_add_8' symbol is undefined. A hint as where to look for a working binary (or which commit to use to generate one), as well as any info regarding lldb-server for MIPS, would be much appreciated.

Thanks,
Andrzej

Hi Nitesh,

Any updates?

Vince

Hi Andrzej, Vince

lldb-server is available for MIPS Linux (both 32 and 64 bit). We are planning to start on Android by end of Jul. We will keep you updated on the progress of this.

For error on ‘__atomic_fetch_add_8’ symbol, could you please try linking with the atomic library?

Regards,

Jaydeep

I just tried to compile lldb-server for Android-MIPS64 and it built without any issue (based on http://lldb.llvm.org/build.html “Example 2: Cross-compiling for Android on Linux”) but I haven’t tried it out how well it works. If I remember correctly the version of Clang shipped with the Android-NDK (Clang-3.5) don’t support all atomic operation used by LLDB so you have to use GCC (shipped with the NDK) to compile LLDB for android.

Regards,
Tamas