lldb-sphinx-docs builder is failing

Hi,

The lldb-sphinx-docs builder has been failing for a while: Buildbot

I think the problem is that python is not installed on the worker, which causes the
docs-lldb-html target to not be created.

-Tom

Hi Tom,

yes, the bot has been failing since a long time but I couldn't reach Dmitri (who is I think maintaining it).

For the record, the required dependencies for the LLDB docs are:
* Python 3 development headers (Something like python3-dev should be enough)
* SWIG (at least version 3).
* the sphinx-automodapi Python package (` pip3 install sphinx-automodapi ` should be enough)

If someone has access to the worker machine and could update it, that would be great. I don't think it's sending out build error messages to my knowledge so it's not very urgent.

Also the docs are built and published by this bot which is green: lab.llvm.org:8011/#/builders/89

Cheers,
- Raphael

Hi Tom,

yes, the bot has been failing since a long time but I couldn't reach Dmitri (who is I think maintaining it).

For the record, the required dependencies for the LLDB docs are:
* Python 3 development headers (Something like python3-dev should be enough)
* SWIG (at least version 3).
* the sphinx-automodapi Python package (` pip3 install sphinx-automodapi ` should be enough)

If someone has access to the worker machine and could update it, that would be great. I don't think it's sending out build error messages to my knowledge so it's not very urgent.

Also the docs are built and published by this bot which is green: lab.llvm.org:8011/#/builders/89

Galina,

It seems like the best option would be to retire the lldb-sphinx-docs bot
since it has been failing for a while and there is another bot that is
building the lldb documentation. Would you be able to retire the bot?

-Tom

Yes, I was about to suggest the same.

Retired in https://github.com/llvm/llvm-zorg/commit/f395d4d0c7d3e9f063d6becd5933d77eb32c1089.

Galina