Looks like this change requires a fix in lldb:
Author: Alp Toker <email@example.com>
SourceManager: Use setMainFileID() consistently
Eliminate createMainFileID() / createMainFileIDForMemBuffer() utility
functions. These didn’t add much convenience and conflated two distinct
This change makes things easier to follow by providing a consistent interface
and getting rid of a bunch of cast-to-voids.
I’ll start looking at this in a few moments. If somebody is already working on a fix, let me know.