LLDB ToT compile fails

Hi,

I built LLDB using xcodebuild two month ago from Top Of Tree (Git).
Today, after pulling the newest version from Git and also of all
dependencies (LLVM, clang, compiler-rt) and run again "xcodebuild
-configuration Release" I got this error:

The following build commands failed:
  CompileC
build/lldb.build/Release/lldb-core.build/Objects-normal/x86_64/CompactUnwindInfo.o
source/Symbol/CompactUnwindInfo.cpp normal x86_64 c++
com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)

I tried it several times in the last two days but it still fails.

I also tried deleting llvm-src/tools/lldb/llvm-build and
llvm-src/tools/lldb/build and building again - but fails, too.

Here is the full log:
https://pastebin.com/9B7MP3Xd

Best regards,
Christian

Looks like you didn’t update LLDB. Your errors look like you have skew between LLDB r228933 and LLVM r228921. If you don’t need LLDB, you can simply delete that part of the checkout.

Sure, I updated LLDB too.

:> cd llvm-src
:> git log -n 1
commit 5e0ce9d13ad5b39c12b68e7af6cf946414bff170
Author: Sanjay Patel <spatel@rotateright.com>

The problem wasn't that I didn't updated LLDB - the problem was that
some files where cached.

Running

  rm -rf build llvm llvm-build lldb.xcworkspace/xcshareddata

before re-compiling with

  xcodebuild -configuration Release

is a good choice. Especially the lldb.xcworkspace/xcshareddata was the
determining factor. After deleting lldb.xcworkspace/xcshareddata I was
finally able to successfully re-compile the ToT version of LLDB.

I created two shell scripts to compile and re-compile it on Mac OS X:
https://gist.github.com/TheFox/028709d7c4d848bf444d

Br,
Christian