llvm-2.2 cannot be successfully built with 'make ENABLE_OPTIMIZED=1'

Hello, Andrew,

I have checked by libstdc++, with a higher version:

         [wuxi@ppidellsc1420 lib]$ rpm -q libstdc++

libstdc++-4.1.1-52.el5

It is lower version. You should use newer version (the one, you've built
during gcc 4.2.3 compilation) for the binaries built with new compiler.

There are two solutions:
1. Build new gcc with --disable-shared, which will lead to huge
binaries, but otherwise will work
2. Replace your system libstdc++ (which is from gcc 4.1.1) to newer
version (which is from gcc 4.2.3). There are different ways, including
symlinking, LD_LIBRARY_PATH stuff, etc.