LLVM 2.8 and MMX

Hi all,

I’ve tested a recent revision and noticed that using 64-bit vectors became very slow. It looks like they are expanded to non-MMX instructions to avoid breaking code which does not clear the MMX state using emms?

For my project I’m already manually inserting emms instructions in the right places, so I’d really like 64-bit vector operations to be lowered to MMX instructions for best performance. So is there some way to get that behavior back? I tried making IsVerbotenVectorType return false but that didn’t appear to help.

I would be very grateful if someone would add a switch to disable the expanding before the 2.8 release is finalized.

Cheers,

Nicolas