LLVM 8.0.0 Release

Hans,
I’d like to make sure that I’m using the right LLVM version.

I tried to download LLVM 8 from the link in your email by cloning this repository:

git clone https://github.com/llvm/llvm-project.git

When I do llc --version, it says LLVM 9.0.0 instead of 8.0.0

LLVM (http://llvm.org/):

LLVM version 9.0.0svn

DEBUG build with assertions.

Default target: x86_64-unknown-linux-gnu

Hans Wennborg via llvm-dev llvm-dev at lists.llvm.org
Wed Mar 20 05:14:45 PDT 2019

I'm pleased to announce that LLVM 8 is now available.

Get it here: [https://llvm.org/releases/download.html#8.0.0](https://llvm.org/releases/download.html#8.0.0)

This release contains the work on trunk up to Subversion revision
r351319, plus work on the release branch. It's the result of the LLVM
community's work over the past six months, including: speculative load
hardening, concurrent compilation in the ORC JIT API, no longer
experimental WebAssembly target, a Clang option to initialize
automatic variables, improved pre-compiled header support in clang-cl,
the /Zc:dllexportInlines- flag, RISC-V support in lld. And as usual,
many bug fixes, optimization and diagnostics improvements, etc.

For more details, see the release notes:
[https://llvm.org/releases/8.0.0/docs/ReleaseNotes.html](https://llvm.org/releases/8.0.0/docs/ReleaseNotes.html)
[https://llvm.org/releases/8.0.0/tools/clang/docs/ReleaseNotes.html](https://llvm.org/releases/8.0.0/tools/clang/docs/ReleaseNotes.html)
[https://llvm.org/releases/8.0.0/tools/clang/tools/extra/docs/ReleaseNotes.html](https://llvm.org/releases/8.0.0/tools/clang/tools/extra/docs/ReleaseNotes.html)
[https://llvm.org/releases/8.0.0/tools/lld/docs/ReleaseNotes.html](https://llvm.org/releases/8.0.0/tools/lld/docs/ReleaseNotes.html)
[https://llvm.org/releases/8.0.0/projects/libcxx/docs/ReleaseNotes.html](https://llvm.org/releases/8.0.0/projects/libcxx/docs/ReleaseNotes.html)

Special thanks to the release testers and packagers: Amy Kwan, Bero
Rosenkränzer, Brian Cain, Diana Picus, Dimitry Andric, Kim Gräsman,
Lei Huang, Michał Górny, Sylvestre Ledru, Ulrich Weigand, Vedant
Kumar, and Yvan Roux.

For questions or comments about the release, please contact the
community on the mailing lists. Onwards to LLVM 9!

Thanks,
Hans

Josh,

That’s the expected behavior. The release version is changed in advance such that the trunk reflects the next release version.

If you want to use 8.0.0 source, you can download the source tarballs or use the git tag that reflects the 80_release branch commit(s). I believe that tag is “llvmorg-8.0.0” .

Thanks, Brian

I tried enabling both the lld and the clang projects by adding -DLLVM_ENABLE_PROJECTS=‘lld;clang’ into the cmake command. After the build completed successfully, I can see ld.lld in my bin folder but not clang. Is it supposed to be in another folder?

Thanks.

Clang should be in the same folder. Can you share the full commands
you used to configure and build?

cmake …/llvm/ -G “Unix Makefiles” -DCMAKE_BUILD_TYPE=“Debug” -DCMAKE_INSTALL_PREFIX=…/install -DLLVM_TARGETS_TO_BUILD=“XXX” -DLLVM_ENABLE_PROJECTS=‘lld;clang;’

-DLLVM_TARGETS_TO_BUILD="XXX" looks wrong, maybe that's causing Clang
to not get built? Can you try setting it to "X86" instead (or just
leaving the flag out)?

I'd also suggest using -DCMAKE_BUILD_TYPE="Release" instead of Debug,
in case you really need full debug info, as this will be much faster
to build.

XXX is the name of my custom CPU architecture

Hi Josh, did you try without the trailing ; in LLVM_ENABLE_PROJECTS and/or list the projects in alphabetic order?
In my experience the CMake config can be sensitive to such details.

XXX is the name of my custom CPU architecture

:smiley:

I simply rebuilt from scratch and it worked