LLVM APT Debian Bullseye Packages for ARM fail to install

I am getting the following errors when trying to install LLVM packages in Debian bullseye docker on ARM64:

#0 6.148 The following information may help to resolve the situation:
#0 6.148 
#0 6.148 The following packages have unmet dependencies:
#0 6.210  clang-14 : Depends: libclang-common-14-dev (= 1:14.0.6~++20221118084105+f28c006a5895-1~exp1~20221118084141.208) but 1:14.0.6~++20230109103058+f28c006a5895-1~exp1~20230109223131.213 is to be installed
#0 6.210  clangd-14 : Depends: libclang-common-14-dev (= 1:14.0.6~++20221118084105+f28c006a5895-1~exp1~20221118084141.208) but 1:14.0.6~++20230109103058+f28c006a5895-1~exp1~20230109223131.213 is to be installed
#0 6.211  libclang-common-14-dev : Depends: libllvm14 (>= 1:14.0.6~++20230109103058+f28c006a5895-1~exp1~20230109223131.213) but 1:14.0.6~++20221118084105+f28c006a5895-1~exp1~20221118084141.208 is to be installed
#0 6.226 E: Unable to correct problems, you have held broken packages.

The same works fine for AMD64. Is there a known issue?