LLVM Error: Unsupported library call operation

Hello,

I am on the hook to instrument a piece of legacy LLVM IR code, and then we are planning to feed to the SeaHorn framework for some model checking tasks.

After the instrumentation, I tried to use llc (version 3.9) to compile the IR code, and it works fine. However, when I try to use llc (version 3.8.1, the default llvm version of SeaHorn) to compile the IR code, it shows the following error:

LLVM ERROR: Unsupported library call operation!

I can dig into the IR code and do some “alpha debugging” to see which part of the IR leads to such issue; however, our legacy code is quite large so it could take a while… Also, I really have no idea on what is “library call operation”… Does it mean some external declared functions? In the IR code we have quite a lot of that.

So could anyone shed some light on this? What would be the general cause of this issue? Thank you. Any advice or suggestions would be appreciated.

Best,
Irene

Hi Irene,

the error means that the IR contains a call to a runtime library function that the backend doesn’t know as of 3.8. You probably created the IR with a different llvm version than tha.

Cheers,
Philip

Hello Philip,

Thank you so much for the info. These legacy LLVM IR code is not produced on my side so I don’t even know the version of the compiler they use…

I tried to do some “delta debugging” and eventually locate the buggy line of the code. So as shown below, the following code cause llc (version 3.8.1) throws the “Unsupported library call operation” issue, but it works fine for llc version 3.9.

Any one can shed some light on this? I still cannot figure a principled way to interpret the error msg. Thanks a lot.

Best,
Irene