llvm-gcc : Did not get a target machine! Triplet is mips64el-unknown-linux-gnu

Hi all,
I met this error(title) when i was trying to compile llvm-gcc-4.2-2.7 on loongson2f,a mips compatible platform.I also failed to build a cross-compiler and the error message was the same . Is that means llvm-gcc cannot support mips back-end now?
Thanks.

Here is my configure options:

$export TARGET=mips64el-unknown-linux-gnu

$…/…/src/llvm-gcc-4.2-2.7.source/configure --target=$TARGET --prefix=$PREFIX --without-headers --disable-shared --disable-nls --enable-checking --with-gnu-as --with-gnu-id --enable-languages=c,c++ --enable-llvm=$(pwd)/…/llvm-2.7 && make all-gcc

Hi all,
I met this error(title) when i was trying to compile llvm-gcc-4.2-2.7 on loongson2f,a mips compatible platform.I also failed to build a cross-compiler and the error message was the same . Is that means llvm-gcc cannot support mips back-end now?

I don’t think that LLVM supports mips64 yet… Bruno?

-Chris

Hi,

Hi all,
I met this error(title) when i was trying to compile llvm-gcc-4.2-2.7 on
loongson2f,a mips compatible platform.I also failed to build a
cross-compiler and the error message was the same . Is that means llvm-gcc
cannot support mips back-end now?

I don't think that LLVM supports mips64 yet... Bruno?

There is some support for 64 bit fp, but not for mips64 though