LLVM-gcc for Ada

Hello,

I'm trying to build LLVM-gcc to compile Ada. But I'm having a few problems.

First thing I did was install gnat 2007. In the bin directory there is a gcc version 4.1. So I think that these versions are good for Ada.

Now when I ran make I get an error that for me it seams very weird.

../../gcc/c-format.c: In function 'set_Wformat':
../../gcc/c-format.c:48: error: 'warn_format_security' undeclared (first use in this function)
../../gcc/c-format.c:48: error: (Each undeclared identifier is reported only once
../../gcc/c-format.c:48: error: for each function it appears in.)
../../gcc/c-format.c: In function 'check_format_info':
../../gcc/c-format.c:1304: error: 'warn_format_security' undeclared (first use in this function)
make[2]: *** [c-format.o] Error 1
make[2]: Leaving directory `/home/andrelct/apps/llvm-gcc/build/gcc'
make[1]: *** [all-gcc] Error 2
make[1]: Leaving directory `/home/andrelct/apps/llvm-gcc/build'
make: *** [all] Error 2

The command I used for ./cofigure was the following:

../configure --enable-languages=c,c++,fortran,ada --disable-bootstrap --disable-nls --disable-multilib --enable-checking --program-prefix=llvm- --prefix=/home/andrelct/apps/llvm-gcc/build/ --bindir=/home/andrelct/apps/gnat-2007/build/bin

Does anyone knows what am I doing wrong? Or can someone help me out?

Thanks,

Hi Andre,

I'm trying to build LLVM-gcc to compile Ada.

excellent!

But I'm having a few problems.

Oops :frowning:

Now when I ran make I get an error that for me it seams very weird.

../../gcc/c-format.c: In function 'set_Wformat':
../../gcc/c-format.c:48: error: 'warn_format_security' undeclared (first use in this function)
../../gcc/c-format.c:48: error: (Each undeclared identifier is reported only once
../../gcc/c-format.c:48: error: for each function it appears in.)
../../gcc/c-format.c: In function 'check_format_info':
../../gcc/c-format.c:1304: error: 'warn_format_security' undeclared (first use in this function)
make[2]: *** [c-format.o] Error 1
make[2]: Leaving directory `/home/andrelct/apps/llvm-gcc/build/gcc'
make[1]: *** [all-gcc] Error 2
make[1]: Leaving directory `/home/andrelct/apps/llvm-gcc/build'
make: *** [all] Error 2

Looks like you forgot to specify --enable-llvm when configuring
llvm-gcc.

Ciao,

Duncan.