LLVM, OCAML, Building

I'm trying to build LLVM & Clang from sources on SL7.

I have installed ocaml, but I still get the following two errors when
running ../llvm/configure

configure: WARNING: --enable-bindings=ocaml specified, but ctypes is
not installed
configure: WARNING: --enable-bindings=ocaml specified, but OUnit 2 is
not installed. Tests will not run

I can't seem to find anything on how to correct these errors.

One recommendation for the 'types' error was to run opam, but opam is
not in the SL7 or EL distros.

I can't find anything on OUnit 2.

Thank you for your assistance.