llvm.org/docs/ stopped updating

Hi,

it seems like http://llvm.org/docs/ stopped updating around 2018-01-03 (the footer at http://llvm.org/docs/ says `Last updated on 2018-01-03`). I've committed a new page [1], on the 4th but it does not show up yet.

I could not find any public logs of the doc-builder. It would be great it someone could have a look.

Cheers,
Florian

[1] https://reviews.llvm.org/diffusion/L/browse/llvm/trunk/docs/Contributing.rst

I believe the results of the docu generation can be found here:

http://lists.llvm.org/pipermail/www-scripts/2018-January/thread.html

(though a nice improvement for the future would be to make this into a buildbot or jenkins job so people would get direct blame mails)

  • Matthias

Thanks Matthias. I had a look at the error mails, but I could not find any errors. But it looks like in all error emails, the LLVM sources are updated to revision 321010, always with the same files changed. Maybe the script got stuck?

The only other suspicious message in the logs is a python warning when running Sphinx:

opt/venv/sphinx/local/lib/python2.7/site-packages/sphinx/util/requests.py:64: UserWarning: Some links may return broken results due to being unable to check the Server Name Indication (SNI) in the returned SSL cert against the hostname in the url requested. Recommended to install "requests[security]" as a dependency or upgrade to a python version with SNI support (Python 3 and Python 2.7.9+).

Cheers,
Florian

I will get this fixed today. Sorry I have been dealing with some family stuff yesterday.

-Tanya

I have fixed the issue. It was due to my addition of the new opcode documentation generation script and some permissions got changed.

-Tanya

Great, thank you very much Tanya!

Cheers,
Florian