llvm-trunk: available files/directories are not found

Hi,

today I've built the latest version of llvm-trunk using Cmake on my "SUSE
Linux Enterprise Server 12.3 (x86_64)" with the following configuration
command (gcc-6.4.0 is necessary for CUDA-9.0).

cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr/local/llvm-trunk \
   -GNinja \
   -DLLVM_TARGETS_TO_BUILD:STRING="NVPTX;X86" \
   -DCMAKE_BUILD_TYPE:STRING="Release" \
   -DLLVM_PARALLEL_COMPILE_JOBS:STRING="4" \
   -DLLVM_PARALLEL_LINK_JOBS:STRING="4" \
   -DCMAKE_C_COMPILER:STRING="/usr/local/gcc-6.4.0/bin/gcc" \
   -DCMAKE_C_FLAGS:STRING="-m64 -I/usr/local/valgrind/include -I/usr/include/ncurses" \
   -DCMAKE_C_STANDARD_LIBRARIES="-lpthread" \
   -DCMAKE_CXX_COMPILER:STRING="/usr/local/gcc-6.4.0/bin/g++" \
   -DCMAKE_CXX_FLAGS:STRING="-m64 -I/usr/local/valgrind/include -I/usr/include/ncurses" \
   -DCMAKE_CXX_STANDARD_LIBRARIES="-lpthread" \
   -DCMAKE_EXE_LINKER_FLAGS:STRING="-m64" \
   -DLLVM_LIBDIR_SUFFIX:STRING="64" \
   -DLLVM_POLLY_LINK_INTO_TOOLS:BOOL=ON \

-DLIBOMPTARGET_DEP_LIBELF_INCLUDE_DIR:STRING="/usr/local/elfutils-0.169/include" \

-DLIBOMPTARGET_DEP_LIBELF_LIBRARIES:STRING="/usr/local/elfutils-0.169/lib64/libelf.so" \
   -DLIBOMPTARGET_DEP_LIBFFI_INCLUDE_DIR:STRING="/usr/include" \
   -DLIBOMPTARGET_DEP_LIBFFI_LIBRARIES:STRING="/usr/lib64/libffi.so" \
   -DCUDA_INCLUDE_DIRS:STRING="/usr/local/cuda/include" \
   -DCUDA_LIBRARIES:STRING="/usr/local/cuda/lib64/libcudart.so" \
   -DBUILD_SHARED_LIBS:BOOL=ON \
   -DOPENMP_ENABLE_LIBOMPTARGET:BOOL=On \
   ../llvm \
   >& tee log.cmake

Unfortunately, xdr.h will not be found although it is available. Adding
"-I/usr/include" to CMAKE_C_FLAGS and CMAKE_CXX_FLAGS didn't solve the
problem.

loki build 155 cat log.cmake | grep xdr.h
-- Looking for rpc/xdr.h
-- Looking for rpc/xdr.h - not found
-- Looking for tirpc/rpc/xdr.h
-- Looking for tirpc/rpc/xdr.h - not found
loki build 156 ls -l /usr/include/rpc/xdr.h
-rw-r--r-- 1 root root 14577 Jun 6 23:26 /usr/include/rpc/xdr.h
loki build 157

The same is true for Python modules pygments and yaml.

loki build 163 cat log.cmake | grep Could
-- Could NOT find OCaml (missing: OCAMLFIND OCAML_VERSION OCAML_STDLIB_PATH)
-- Could NOT find Python module pygments
-- Could NOT find Python module yaml
loki build 164 python -V
Python 2.7.13
loki build 165 ls -l /usr/lib64/python/site-packages/yaml
total 452
-rw-r--r-- 1 root root 9776 Aug 29 2016 __init__.py
-rw-r--r-- 1 root root 11410 May 26 2017 __init__.pyc
-rw-r--r-- 1 root root 4921 Aug 29 2016 composer.py
...
loki build 166 ls -l /usr/lib/python2.7/site-packages/pygments
total 348
-rw-r--r-- 1 root root 3145 Jul 31 13:03 __init__.py
-rw-r--r-- 1 root root 3490 Jul 31 13:03 __init__.pyc
-rw-r--r-- 1 root root 19326 Jul 31 13:03 cmdline.py
...

Is it necessary that I add something to my configuration command so that
the files/directories will be found or is it a problem of a configuration
file in llvm-trunk? Thank you very much for any help in advance.

Kind regards

Siegmar