LLVM version with working Alpha backend

Hi,

For my work, I want to use LLVM to compile SPEC 2k for Alpha. Since Alpha support has been dropped, I tried using version 2.8, but it is quite buggy, probably because the Alpha backend has not been maintained. I was wondering if there is an earlier version where the Alpha backend is stable enough to compile SPEC 2k? For my purpose, I do not need the most advanced optimizations, so an earlier version with stable and reasonably optimized Alpha backend will do.

Thank you,

Giang Hoang

Hi Giang,
Given that the community deprecated the Alpha backend, I'm doubtful anyone would be able to point you in the right direction. Have you iteratively tried the difference versions of LLVM (i.e., 2.9, 2.8, 2.7 on down the line)?

Chad

Thank you Chad. Trying iteratively is exactly what I am doing, but it will take some time. I just wanted to see if anyone knows, then that would save me some time.

Giang