LNT install

I followed the lnt quickstart directions but got this diagnostic when doing the setup:

bash-3.2$ ~/mysandbox/bin/python ~/lnt/setup.py develop

/Users/dcallahan/mysandbox/lib/python2.7/site-packages/setuptools/dist.py:284: UserWarning: The version spec\

ified requires normalization, consider using ‘0.4.1.dev0’ instead of ‘0.4.1dev’.

Subsequently I get this error: >

/Users/dcallahan/mysandbox/bin/lnt runtest nt --sandbox /Users/dcallahan/tmp/sand --cc /Users/dcallahan/bu\

ild/Debug+Asserts/bin/clang --test-suite /Users/dcallahan/llvm-test-suite

error: installed distribution LNT 0.4.1.dev0 is not current (LNT 0.4.1dev), you may need to reinstall

LNT or rerun ‘setup.py develop’ if using development mode.

Any pointers on what might be going wrong?

Thanks

david

Hi David,

That's weird, I have setup LNT in multiple different distros and have
never seen this. Looks like no one ever tested on the system you're
running. Can you share a bit more of your environment?

Also, you can check the setup.py to see if it does any stripping of
package names, which could go wrong in the wrong environment.

cheers,
--renato

Thanks for the reply Renato.

I modified lnt/lnt/__init__.py and that seemed to fix my problem.

‹david

Index: lnt/__init__.py

I believe I fixed that problem here:
http://llvm.org/viewvc/llvm-project?view=revision&revision=227360

  • Daniel