lnt issue- Could not find required distribution six==1.9.0

Dear Community members,

I am trying to setup lnt on a system where I do not have sudo access.
I am facing the following issue. Kindly suggest a solution.

virtualenv version => 1.11.6
OS => Debian with kernel 3.16.7

While installing lnt into a virtual environment, I am getting the following error -

Processing six-1.9.0.tar.gz
Writing /tmp/easy_install-ZBhMFI/six-1.9.0/setup.cfg
Running six-1.9.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-ZBhMFI/six-1.9.0/egg-dist-tmp-fhACLO
no previously-included directories found matching ‘documentation/_build’
zip_safe flag not set; analyzing archive contents…
six: module references path
six 1.8.0 is already the active version in easy-install.pth

Installed /home/xxx/xxx/workBox/lib/python2.7/site-packages/six-1.8.0-py2.7.egg
error: Could not find required distribution six==1.9.0

When I run lnt, I am getting the following error-

pkg_resources.DistributionNotFound: six==1.9.0

Hi Utpal,

did you try installing six 0.9 manually into the virtual environment
or your user site-packages?

six 1.9 available here: six · PyPI

$ cd <your virtualenv root dir>
$ source bin/activate
$ pip install six==1.9.0

or

$ cd <your virtualenv root dir>
$ source bin/activate
$ easy_install six==1.9.0

Michael

What Michael mentioned should work. Alternatively, you can try to upgrade pip inside the virtualenv:

pip install --upgrade pip

- Vasileios

Thank you Michael and Vasileios. The issue is fixed.