Logging in to Phab with a Google account broken for anyone else?

Hi,

I log in to Phab using my @chromium account with the “Log In or Register Google” button on https://reviews.llvm.org/auth/start/?next=%2F . That has worked fine for me, but now it fails with

Auth > Unhandled Exception ("Exception")

Expected to retrieve an "account" email from Google Plus API call to identify account, but failed.

Is anyone else seeing this? Is this a known issue?

Thanks,
Nico

Yes this was broken for me too, there was another post on here about this a few weeks ago too. I forget what I did to fix it. I think I just logged in with my email and somehow got my account back, I think because I used the email associated with that google account. I forget what I used for my password though.

Thanks for the reply. Typing in my username and clicking “Forgot password?” got me a link I could use to log in.

It’d still be good if federated login worked again. Is there an upstream issue for this?

Another workaround is to use a github account to authenticate.

Presumably this wouldn’t allow you to recover your old Google associated account, right?

I don’t think so. But if you have a machine, where you’re still logged in, you can add the github account…