Make dragonegg work with gcc-4.6

Hi, Duncan

  I saw you started to port dragonegg to gcc 4.6, which is a good news.
And I am also trying to do that. The attachment get src/Convert.cpp to
compile against gcc-4.6.

  Now I get a error while compiling dragonegg,

patch-dragonegg-133342 (1.2 KB)