Many PPC64 failures with llvm 3.3

Hi,

I am building llvm 3.3 with cmake on PPC64 and have a bunch of regression test failures. With only PPC backend enabled the list of failures is:

[ 1553s] Failing Tests (20):
[ 1553s] LLVM :: CodeGen/PowerPC/2007-05-22-tailmerge-3.ll
[ 1553s] LLVM :: CodeGen/PowerPC/2007-09-08-unaligned.ll
[ 1553s] LLVM :: CodeGen/PowerPC/2008-07-24-PPC64-CCBug.ll
[ 1553s] LLVM :: CodeGen/PowerPC/available-externally.ll
[ 1553s] LLVM :: CodeGen/PowerPC/branch-opt.ll
[ 1553s] LLVM :: CodeGen/PowerPC/stubs.ll
[ 1553s] LLVM :: DebugInfo/debuglineinfo.test
[ 1553s] LLVM :: DebugInfo/dwarf-public-names.ll
[ 1553s] LLVM :: DebugInfo/dwarfdump-debug-frame-simple.test
[ 1553s] LLVM :: DebugInfo/dwarfdump-inlining.test
[ 1553s] LLVM :: DebugInfo/dwarfdump-pubnames.test
[ 1553s] LLVM :: DebugInfo/dwarfdump-test.test
[ 1553s] LLVM :: DebugInfo/dwarfdump-zlib.test
[ 1553s] LLVM :: DebugInfo/llvm-symbolizer.test
[ 1553s] LLVM :: DebugInfo/member-pointers.ll
[ 1553s] LLVM :: DebugInfo/namespace.ll
[ 1553s] LLVM :: DebugInfo/two-cus-from-same-file.ll
[ 1553s] LLVM :: Object/objdump-symbol-table.test

Full log is attached. Any ideas would be appreciated.

Regards,
ismail

ppc64-log.txt (34 KB)

After some head scratching and debugging it turns out that disabling shared libs fixes the problem. This might be related to http://llvm.org/bugs/show_bug.cgi?id=13124 . It would be nice to get this finally fixed otherwise cmake + shared libs is no go.

Thanks.

After some head scratching and debugging it turns out that disabling
shared libs fixes the problem. This might be related to
http://llvm.org/bugs/show_bug.cgi?id=13124 . It would be nice to get
this finally fixed otherwise cmake + shared libs is no go.

Thanks for investigating this! We should probably move future conversation onto the bug report, but this does look like a serious problem.

-Hal