Matching clang versions with gcc backends

On Windows I have a number of versions of mingw(-64)/gcc installed. I also have clang 3.4 through 3.9 installed as well as building the latest clang 5.0 from source targeting gcc using gcc 6.3.

Other than the latest clang 5.0 I have built from source using gcc 6.3 is there any way, other than trial and error, to determine which backend version of gcc a particular released version of clang will work with correctly ?