Minor change request

A recent change did this

In kmp_platform.h (which is included in z_Linux_asm.s) there is this definition of KMP_OS_DARWIN:

#if ( defined __APPLE__ && defined __MACH__ )
# undef KMP_OS_DARWIN
# define KMP_OS_DARWIN 1
#endif

I changed it because it is cleaner and it is consistent with the rest of the code.

-- Johnny