Naming convention of LLVM dynamic library

I’ve got a question related to the versioning of LLVM as a dynamic library.
I’m currently working on LLVM10.

In case building LLVM and clang with added LLVM_BUILD_LLVM_DYLIB there appears
Why is it instead of
Is there any particular reason for such naming compared to the naming convention of other shared objects?
For example: →