--no-stdin mode kicks in without warning (?)

Hi,

I never do --no-stdin, because the program I'm debugging often takes
input. If I debug in one of the normal sessions for an extended period
of time, 'continue' returns the (lldb) prompt immediately, which
claims that the program is running (it's actually waiting for input).
At this point, I have no choice but to start over, because there's no
way to go from the --no-stdin mode to the normal mode (?).

I'm not able to give reproduction steps, but I think it has to do with
the program being multi-threaded?

Ram

It more likely has something to do with LLDB being multi-threaded and
failing to push the process IO handler on stack. It sounds like a bug,
but it's hard to diagnose without more info. Could you try enabling
logging (log enable -f some_file.txt lldb process) and send that over
when this problem hits. Maybe we can dig something up from that.

cheers,
pl