Ocaml binding tests are failing

Hi Peter,

Could you take a look at this failure?

http://lab.llvm.org:8011/builders/llvm-clang-lld-x86_64-debian-fast/builds/35168/steps/test/logs/stdio

Dmitri

It’s known to be failing right now because of recent changes, but I’m curious why that bot has ocaml installed for the bindings?

-eric

It's known to be failing right now because of recent changes, but I'm
curious why that bot has ocaml installed for the bindings?

I would guess because I've been asking for OCaml to be installed
for quite some time :slight_smile:

It’s known to be failing right now because of recent changes, but I’m
curious why that bot has ocaml installed for the bindings?

I would guess because I’ve been asking for OCaml to be installed
for quite some time :slight_smile:

Heh. Of all the timing :slight_smile:

-eric

It's known to be failing right now because of recent changes, but

I'm

curious why that bot has ocaml installed for the bindings?

I would guess because I've been asking for OCaml to be installed
for quite some time :slight_smile:

Heh. Of all the timing :slight_smile:

I'm trying to move cross-continent so I don't have time to implement
the (fairly substantial) proper fix to the breakage right now, but I'll
do it ASAP, probably around 2nd.

Sounds good, thanks for the heads up.

Hi,

I understand you might not have the time to fix the tests right now.
Could you XFAIL them in the meantime though?

Dmitri

I’ve done this temporarily:

commit db58ab320826671ca152b0c714fbf8d506383e67
Author: Eric Christopher <echristo@gmail.com>

Make the OCaml tests temporarily unsupported until they can be updated.

git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@259954 91177308-0d34-0410-b5e6-96231b3b80d8

http://lab.llvm.org:8011/builders/llvm-clang-lld-x86_64-debian-fast/builds/35322

-eric