Onnx mlir installation error while building

while building onnx-mlir i got the following error, so i request to resolve this error

/home/dkm/onnx-mlir/src/Conversion/KrnlToLLVM/KrnlToLLVM.cpp: In function ‘void mlir::populateAffineAndKrnlToLLVMConversion(mlir::OwningRewritePatternList&, mlir::MLIRContext*, mlir::LLVMTypeConverter&)’:
/home/dkm/onnx-mlir/src/Conversion/KrnlToLLVM/KrnlToLLVM.cpp:1029:3: error: ‘populateStdExpandDivsRewritePatterns’ was not declared in this scope
1029 | populateStdExpandDivsRewritePatterns(ctx, patterns);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
make[2]: *** [src/Conversion/KrnlToLLVM/CMakeFiles/OMKrnlToLLVM.dir/build.make:63: src/Conversion/KrnlToLLVM/CMakeFiles/OMKrnlToLLVM.dir/KrnlToLLVM.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:3606: src/Conversion/KrnlToLLVM/CMakeFiles/OMKrnlToLLVM.dir/all] Error 2
make: *** [Makefile:141: all] Error 2

Iirc, that project is pinned to a specific version of llvm/mlir, and this looks like API drift to me. I’m not sure if the relevant people from that project are paying attention here and you may want to file an issue with the project if syncing to the right revision doesn’t help.