opt -dot-cfg

I use “opt -dot-cfg sample.bc” command to view cfg, but I encountered the following warning.

WARNING: You’re attempting to print out a bitcode file.
This is inadvisable as it may cause display problems. If
you REALLY want to taste LLVM bitcode first-hand, you
can force output with the `-f’ option.

I see unmeaning thing when use -f , in additinal I’ve installed graphvis software,
can anyone help me?

You need to tell opt where to put the resultant output file. It's still going to do that even with the graphvis display stuff. "opt -dot-cfg sample.bc -o sample.out.bc" or something like that.

-Jim