[PATCH 1/2] Fix build with LLVM 3.3

Hi,

Peter can correct me if I'm wrong, but based on previous changes, I don't
think that libclc is meant to support multiple llvm versions. So,
you can probably drop the ifdefs from this patch.

-Tom