[PATCH] Correct bit_SSE4* macro names to match gcc.

These have been incorrect since they were added to clang, and wouldn't
have been useful to programs without additional workarounds.

We need a test case for this patch at the least.

I also wonder if we shouldn’t support both names to avoid breaking any code that has been written to Clang and never tested with GCC? Supporting both names in this particular context seems less onerous than usual.

We need a test case for this patch at the least.

Seems like test driven development gone too far, but okay. Point me in
the right direction? And test what exactly, that the macro with the
fixed name exists?

I also wonder if we shouldn't support both names to avoid breaking any code
that has been written to Clang and never tested with GCC? Supporting both
names in this particular context seems less onerous than usual.

I'd say no, because it only allows people to write code that's
incompatible with the original cpuid.h implementation provided by gcc.