Please upgrade GCC (to 4.7 or above) on hpproliant1 in the llvm lab

Hi Galina,

I seem to be having trouble connecting to the llvm lab using my existing pubkey. (“Permission denied (publickey)”.

The machine running the GDB 7.5 test suite has been failing recently due to a valid change that seems to only break under GCC 4.6, which is no longer a supported compiler for LLVM.

If you could restore my access to the lab (or help me debug it - I may’ve broken something on my end, I’m still looking into it/cross checking) and I’d need sudo/aptitude privileges on the machine for a while too - and/or if you could upgrade the default gcc on that machine, that would be great. Thanks!

  • Dave

Hi David,

I seem to be having trouble connecting to the llvm lab using my existing pubkey.

Could you try it again please? It should work now.

Thanks

Galina

Hi David,

>I seem to be having trouble connecting to the llvm lab using my existing
pubkey.
Could you try it again please? It should work now.

Thanks - I can now ssh into the lab with my pubkey. But I can't seem to ssh
from the main machine (macpro1) to my bot (hpproliant1) - are access keys
not setup between these machines, perhaps? (I think previously I've made
that connection without any extra authentication steps - but perhaps I'm
misremembering)

(& it turns out I don't need to upgrade the GCC on this buildbot just yet -
it's probably running a supported version, but it'd be good to have access
so I can check/fix if necessary/etc)

- Dave