poolalloc error: ‘addPeakMemoryMeasurement’ is not a member of ‘llvm::Timer’

Hi there,

I checked out the poolalloc project from svn repository. I got the error ‘addPeakMemoryMeasurement’ is not a member of ‘llvm::Timer’ while compiling. Does poolalloc only compile under LLVM 2.7 or earlier, but not the LLVM under development?

Thanks,
Guoliang

Guoliang Jin wrote:

  Hi there,

I checked out the poolalloc project from svn repository. I got the error ‘addPeakMemoryMeasurement’ is not a member of ‘llvm::Timer’ while compiling. Does poolalloc only compile under LLVM 2.7 or earlier, but not the LLVM under development?
  
That is correct. Mainline poolalloc compiles with LLVM 2.7. The release_26 branch of poolalloc compiles with LLVM 2.6.

-- John T.